Drupal任意PHP代码执行漏洞风险通告,腾讯安全支持全面检测

2020-11-26 13:08:52
Drupal官方发布安全更新,披露了一个任意PHP代码执行漏洞,攻击者可利用该漏洞执行恶意代码,入侵服务器。

Drupal官方发布安全更新,披露了一个任意PHP代码执行漏洞,攻击者可利用该漏洞执行恶意代码,入侵服务器。 

漏洞描述:

Drupal项目使用PEAR Archive_Tar库,PEAR Archive_Tar库已经发布了影响Drupal的安全更新。如果将Drupal配置为允许.tar.tar.gz.bz2.tlz文件上传并处理它们,则可能存在多个漏洞。漏洞被利用可导致任意的PHP代码执行。

Drupal 是由德赖斯·布伊泰尔特创立的自由开源内容管理系统,用PHP语言写成。在业界,Drupal常被视为内容管理框架(CMF),而非一般意义上的内容管理系统(CMS)。

 

漏洞编号:

CVE-2020-28949

CVE-2020-28948

 

漏洞等级:高风险

 

受影响的版本:

Drupal 7系列,版本号< 7.75

Drupal 8.8系列,版本号< 8.8.12

Drupal 8.9系列,版本号< 8.9.10

Drupal 9.0系列,版本号< 9.0.9

 

安全版本:

Drupal 9.0.9

Drupal 8.9.10

Drupal 8.8.12

Drupal 7.75

 

修复建议:

1)官方已发布安全版本,检查您的Drupal是否在受影响版本范围,如受影响,请你选择合理时间进行升级操作,升级到安全版本,避免影响业务。 

下载链接:

    https://www.drupal.org/project/drupal/releases/9.0.9

    https://www.drupal.org/project/drupal/releases/8.9.10

    https://www.drupal.org/project/drupal/releases/8.8.12

    https://www.drupal.org/project/drupal/releases/7.75

 

【备注】:建议您在升级前做好数据备份工作,避免出现意外。 

2)临时缓解方案:可以通过禁止不受信任的用户上传.tar.tar.gz.bz2.tlz文件,缓解此问题。

 

腾讯安全解决方案:

1.腾讯T-Sec主机安全(云镜)漏洞库日期2020-11-26之后的版本,已支持对Drupal任意PHP代码执行漏洞进行检测;

2.腾讯T-Sec云防火墙规则库日期2020-11-26之后的版本,已支持对Drupal任意PHP代码执行漏洞利用进行检测和拦截,

腾讯云防火墙内置的入侵防御功能,使用虚拟补丁机制防御最新的漏洞利用;

3.腾讯T-Sec高级威胁检测系统(御界)规则库日期2020-11-26之后的版本,已支持对Drupal任意PHP代码执行漏洞利用的攻击检测;

4.腾讯T-Sec Web应用防火墙已支持防护Drupal任意PHP代码执行漏洞攻击。


参考链接:

https://www.drupal.org/sa-core-2020-013

最新资讯